"Enter"a basıp içeriğe geçin

ESXi Upgrade – “Software or system configuration of host is incompatible” hatası

Last updated on 28 Ocak 2021

ESXi sunucumuzu vSphere ESX 7.0 sürümüne yükseltmeye çalışırken aşağıdaki hata ile karşılaştım.

Remove the VIBs or use Image Builder to create a custom upgrade ISO image that contains the missing dependencies, and try to upgrade again.

Hata mesajı vCenter Lifecycle Manager tarafından açıkca belirtilmekte idi. Hata mesajında sorunun nereden kaynaklandığı belirtiliyor ancak gerçekten hangi paket içerisinde hangi vib dosyası barındırılıyor bunu belirlemek gerekiyor. Bu işlemi gerçekleştirebilmek adına aşağıdaki komut ile kurulu vib listesini çekebiliriz.

esxcli software vib list

VIB dosyalarını inceleyip ihtiyacımız olan vib dosyasını belirledikten sonra aşağıda belirtilen komut ile ilgili paketi kaldırabiliriz. (Paketi hala nasıl belirledik diye düşünürsek Lifecycle üzerinde üreticiye ait bilgi yazdığı için ben ilgili üreticinin isminin geçtiği paketleri kaldırarak ilerledim)

esxcli software vib remove -n <VIB name>

-n paket adı -n paketadı belirterek bir seferde birden fazla paketi kaldırabilirsiniz.

Paketleri kaldırdıktan sonra esxi yapımızı hızlı bir şekilde reboot edip, upgrade işlemimizi tekrardan denediğimizde hata alınmadığını göreceğiz.

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.