"Enter"a basıp içeriğe geçin

Zabbix DB Error – database could be upgraded to use primary keys in history tables

Zabbix upgrade sonrası DB güncellenirken loglarda aşağıdaki şekilde uyarı aldım, ilgili işlem tamamlanamadığı için sürecim başarısız olmakta ve başa dönmekteydim.

DB ortamım mysql v8 olarak çalımaktadır. Zabbix forumlarını incelediğimde mysqlv8 kullanan kullanıcılarda bu durumun olduğu ve root kullanıcısı ile mysqle login olup aşağıdaki komutu çalıştırdığımda sorunun giderileceği üzerine idi,

SET GLOBAL log_bin_trust_function_creators = 1;

ve ek olarak, ilk kurulum ve upgrade adımları için öncelikle desteklenen sürümlerinde içerik arasında bilgisini düşmüşler. Bu adım ile ben sürecimi başarılı şekilde tamamladım, direk db loglarını incelediğimde sonuç aşağıdaki gibiydi,

başka bir yazımızda görüşmek üzere,

Bir cevap yazın

E-posta hesabınız yayımlanmayacak.